Jump to content


Photo

Texture Editor


  • Please log in to reply
14 replies to this topic

#1 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 31 October 2017 - 09:57 AM

I noticed a few times that some textures appear to have really bizarre settings, but had not really thought much about it.

 

However, it's now getting to the stage where it's becoming an annoyance ...

 

Softplan has standard settings for all it's textures, that gives each texture it's optimum appearance. but it seems that when you edit the properties of a texture for a specific project, that texture "remembers" the edited settings permanently. Which is wrong!

 

I have a number of textures that I've used as "display colour" so that I can match a texture to a painted surface or non- textured surface. I also have a number of textures that I've resized or rotated on specific projects. It seems that these ONE OFF edits are being saved as permanent changes to my textures, and it's getting to the point where a lot of my textures have been edited enough that I've no idea what the original settings are, and I seem to be spending more and more time trying to reset these textures (especially the resized ones) to the original sizes, colours, rotations etc. ... Has anyone else come across this, or is it something I've done?

 

Is there any way to reset the texture library to "FACTORY" defaults?


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#2 Thomas Roman

Thomas Roman

    Advanced Member

  • Members
  • PipPipPip
  • 320 posts
  • LocationSacramento, CA

Posted 31 October 2017 - 10:37 AM

I think the answer is yes..

 

while in the 3D tab:

 

File Button > Material File > Load > Default Folder .> 3D (or as appropriate)



#3 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 31 October 2017 - 11:25 AM

But doesn't the default folder load for every new project? I'm getting issues with the textures that go back to textures used many projects ago. It seems that every change edits the default material file ... maybe I'm wrong.

 

I suspect that those may also be the default materials for the standard project, i.e. siding 10, carpet 17 etc. Not specifically the settings for those default materials.


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#4 Doug Morell

Doug Morell

    Advanced Member

  • Members
  • PipPipPip
  • 393 posts
  • Location..

Posted 31 October 2017 - 12:15 PM

Are not Textures .jpg files .. ?

 

Can you not copy and rename a particular .jpg prior to personalizing it .. ?


.. invariably, someone will have a simpler solution.


#5 Thomas Roman

Thomas Roman

    Advanced Member

  • Members
  • PipPipPip
  • 320 posts
  • LocationSacramento, CA

Posted 31 October 2017 - 12:36 PM

Keith..

 

when starting a new project, do you use PREVIOUS when selecting a rendering style?... or perhaps copy / paste files from project folder to project folder (and thus copying materials file) ?

 

The files in my Default Materials File haven't changed since my install... So I'm not sure what file SoftPlan is using for the Materials set-up on your new projects...

 

in any event, it will just take a moment to use the Material File > Load > Default



#6 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 31 October 2017 - 01:25 PM

My rendering style is custom, and I always LOAD my specific rendering style, but always start off with the default material file.

 

I NEVER copy and paste project files. All projects are Custom tailored to the specific customer.

 

However, as I said earlier, there are numerous materials that show as having being edited at sometime ... either for DISPLAY COLOUR, SIZE or ROTATE etc.

 

I'll have to investigate further ... I have a number of Custom colour schemes, and a CUSTOM DEFAULT MATERIAL file. but as far as I 'm aware, the custom material file was just my preferred materials ... not customized as to size etc. and it hasn't changed since I created it for materials. As far as I'm aware.

I have a copy of the DEFAULT 3D material file. I'll reload that, resave as default, and see how that goes.

 

I'm NOT saying that this isn't my own fault, but for the life of me I don't see how I messed it up ...


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#7 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 31 October 2017 - 01:40 PM

Are not Textures .jpg files .. ?

 

Can you not copy and rename a particular .jpg prior to personalizing it .. ?

 

Yes, they are either JPG's or PNG's ... it's not the specific JPG that's been changed ... it's the settings - SIZE or ROTATION or COLOUR or OPACITY etc. - that control its appearance via the texture editor control panel that all seem to be all over the place. I hasten to add that not everything for all textures have changed. Just odd items for a lot of textures are off.

 

It's hard to quantify the changes, but take this for an example: These are my textures the JPG's were created by me and supposedly all identical except for colour.

 

Attached File  2017.10.31_15h32m54s_001.png   102.79KB   1 downloadsAttached File  2017.10.31_15h33m20s_002.png   87.08KB   1 downloads

 

At some point I changed the red in a project. to "display colour" to colour a trim so that it matched the metal. However, now when I use it comes up with display colour as the default. I'm sure that when I change it back it will then default to display texture from now on. I have lots of examples that show changed size OR changed display OR changed opacity. It does seem that when I change it it stays that way for all projects until it's changed back in the next useage.

 

My issue is actually physically having to change it back ... because at some point I changed it, and it stayed changed even in the next project.

 

TRY THIS:

 

1). In a project pick an unusual texture and edit the VERTICAL size to something far too big.

2). Close the project and open an existing project.

3), Edit a material to the texture you just edited in your previous project.

 

Does it now exhibit the size you JUST edited it too? MINE DOES ...

 

As far as I'm concerned it shouldn't ... the size change (and any other changes) should have been specific to the last project, since the last customer had an existing outsize siding or whatever. That change should not be remembered and should not affecting the settings for FUTURE or PREVIOUS projects.


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#8 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 31 October 2017 - 01:57 PM

The files in my Default Materials File haven't changed since my install... 

 

No, but I can almost bet that some of the settings for some of those materials have been changed. Sometime ... Somewhere ...


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#9 Doug Morell

Doug Morell

    Advanced Member

  • Members
  • PipPipPip
  • 393 posts
  • Location..

Posted 31 October 2017 - 02:06 PM

Keith, ..

 

I haven't gone to the extent you've suggested to test things out, ..

 

.. but I can see your point, .. simply changing the Texture Map Type from Box to say, .. Spherical ..  seems to (re)set the default at Spherical regardless of which texture library

 

you choose next .. you have to manually change the next back to 'box' ..


.. invariably, someone will have a simpler solution.


#10 Kevin Rabenaldt

Kevin Rabenaldt

    Advanced Member

  • Members
  • PipPipPip
  • 391 posts
  • LocationSan Antonio

Posted 31 October 2017 - 02:39 PM

What I started doing on textures that I modify and use all the time is;

 

Create a box

Paint your texture

Modify

Save as a drawing in a Project named Textures (for example, name whatever you wish)

Do as many boxes and textures as you need in your source drawing saved under your Project named Textures.

Copy these boxes into whatever drawing you need them

Do a Draw, Select, and then paint your texture.

 

I don't know if this would satisfy all your needs.  If you can save a particular box as described with a texture in it as a symbol and it keeps all the changes after you insert the symbol and then explode, well I have not tried that.

 

And someone may have a better way than I am using.



#11 Thomas Roman

Thomas Roman

    Advanced Member

  • Members
  • PipPipPip
  • 320 posts
  • LocationSacramento, CA

Posted 31 October 2017 - 05:15 PM

I understand Keith..

 

I'm not clear how SP functions when generating an initial 3D for a project.. I guess the assumption we're making is that it reaches out to a default materials setting... 

 

but now that you bring it up, I guess perhaps I see some of what you describe also... so uncertain, it is..



#12 Luke Wright

Luke Wright

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 12 March 2022 - 08:33 PM

Keith,

 

Did you find a solution for this problem? 

I am having the same issue.



#13 Keith Almond

Keith Almond

    Advanced Member

  • Members
  • PipPipPip
  • 4,848 posts
  • LocationBrockville, Ontario, Canada

Posted 12 March 2022 - 09:10 PM

Nope, sorry, never did.


Keith

There are 10 types of people in this world ....... Those who understand binary, and those who don't.

Softplan user since version 5.5.2.5

www.homehardwarekingston.ca

#14 Luke Wright

Luke Wright

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 12 March 2022 - 09:16 PM

I can't seem to fix it either.

 

I was working on this project late last night. The exterior walls looked similar to the stucco under the display texture.

Now its black & a completely different texture. 

 



#15 Luke Wright

Luke Wright

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 12 March 2022 - 09:27 PM

these are the current options

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users