Jump to content


2018 .spd will not open in 2018 after installing 2020

  • Please log in to reply
2 replies to this topic

#1 Jeffrey Stark

Jeffrey Stark


  • Members
  • Pip
  • 7 posts

Posted 20 March 2021 - 06:00 PM

Here's something that has me jumping up and down. I have tried to open files in 2018 after subscribing to SoftPlan + and upgrading to 2020. All my .spd and .spp files that were saved in 2018 will not open anymore in 2018. I was under the impression that you could still run 2018 and open all the projects and files saved in 2018. I know that if you save any project or file in 2020 then you have to use 2020 from then on to access that project or file. I have not saved these files in 2020 but when I run 2018 and open any 2018 file a popup comes up that says "The project was created with a newer version and cannot be read by this version." The problem is that the project was never created by the newer version and not saved in the newer version in the first place. It was created in 2018 and that is what I'm trying to open it with, not 2020. It's like all .spd and .spp files have been converted so that 2020 has to be used. Like I said, jumping up and down.


Why don't I just use 2020? I just don't feel like mixing and matching. I want 2018 to stay 2018 and not half 2020 and half 2018. That's a recipe for disaster. Got enough issues with file management already. And I don't plan to use SoftPlan + forever. I already own 2018 and it works for me. Or used to.


SoftPlan is a great piece of software but sometimes the random glitches and haywires that come out of nowhere drive me crazy.

#2 Jason Bishop

Jason Bishop

    Advanced Member

  • Members
  • PipPipPip
  • 271 posts

Posted 20 March 2021 - 06:10 PM

When you installed 2020 did you rename the ‘Softplan’ folder?

If you want two different versions (or more) you have to direct the program to install in a different location (folder) or it will just override the last version.

I have 2018 loaded in my folder Softplan2018 and 2020 loaded in Softplan2020 and so forth.

You have to rename the destination folder when you do the install for this to work.

Maybe, just maybe, you can reload 2018 doing what I said above. Create a new project in 2018. Go to the recovery folder of your job and copy an old SPD file and paste in the new project folder. I have not tried this, but it may work.

Good luck.

#3 Don Gibbons

Don Gibbons

    Advanced Member

  • Members
  • PipPipPip
  • 375 posts

Posted 21 March 2021 - 02:50 PM

I run several versions of SoftPlan and that message occurs for me when I have already opened that project in a newer version and forgot that I did so.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users