Jump to content


Photo

Calculating Plumbing cost by adding plumbing symbols

softlist symbol formula plumbing material definition

  • Please log in to reply
9 replies to this topic

#1 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 09:51 AM

Hi, I am trying to create what should be a simple formula but can't get anything to come out.

 

Our plumber charges for labor by charging $650 per plumbing drop.

 

So to calculate this all I need to do is create a formula that adds all sinks/toilets/refrigerator/baths/showers and charges $650 per item.

 

I have been trying to do this by adding a material definition that uses the symbol type, and setting it to find library items that are tagged Bathroom/Tub/Sink/Plumbing etc. and then calculate the quantity with a set price of $650 per item. Yet nothing happens. I have never used a symbol type material definition so I'm in uncharted territory.

 

Yes, I know I could use the Bath fixtures/Kitchen fixtures etc library items in the softlist report, but that would make our accountant have to change how they do their reports, and this should be a simple formula to make anyways.

 

Here is what my formula looks like so far

Softlist pic.jpg



#2 Philip Frank

Philip Frank

    Advanced Member

  • Members
  • PipPipPip
  • 418 posts
  • LocationMaine, USA

Posted 28 September 2017 - 10:05 AM

Try changing the radio button in the lower left from " Calculate Quantity" to "Quantity = 1"



#3 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 10:12 AM

Tried that. Still nothing :/



#4 Philip Frank

Philip Frank

    Advanced Member

  • Members
  • PipPipPip
  • 418 posts
  • LocationMaine, USA

Posted 28 September 2017 - 11:29 AM

Do the plumbing symbols actually have the tags assigned to them?

 

Try editing the symbol and then going to the SoftList tab. Click on " List material" and see if it gives you any results.

 

Has the material definition that you created been added to your SoftList layout? If it hasn't, it won't show up in your report,



#5 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 11:37 AM

Yes the tags are assigned to the symbols, and the material definition is in the soflist layout. I managed to get it to at least calculate something by setting it to search for ID=10, which is what the ID number is set to for plumbing symbols, but it ends up detecting 60+ units. But then I changed the ID for plumbing symbols to 1234 and set the formula to search for ID=1234 and then nothing shows up! I'm at a loss here, just trying random things to see if something works now. 



#6 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 11:47 AM

Here is a snapshot of what my symbol library looks like

 

O2S7NFa.jpg



#7 Derrik Bauer

Derrik Bauer

    Advanced Member

  • Members
  • PipPipPip
  • 228 posts

Posted 28 September 2017 - 12:24 PM

I created a formula to add an outlet for every window well.  Here is how I did it:

 

1.jpg



#8 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 01:01 PM

I have tried using an accumulate formula, and it works. The only problem is that I would have to create a material for EVERY plumbing symbol and set them all to accumulate to one material.

 

After messing around with the symbol ID setting, I have noticed that it doesn't actually update the ID after you change it. For example I tried setting the ID for all fixtures to 1234, then setting the material definition to detect all symbols with that ID but got nothing to register. BUT if I set my material formula to search for ID 10 (which is the default plumbing fixture ID) it will detect those fixtures that originally had an ID of 10, even though their ID is listed as 1234 on plan and in the symbol definition. It's like softlist isn't detecting the changes I make to the ID numbers. 



#9 Jamie Abshire

Jamie Abshire

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 September 2017 - 02:23 PM

Alright I found the solution. It looks like my formula was correct to begin with, but when changing ID numbers softplan doesn't register the change very well. The only solution I found was to start a new project. In the new project Softlist was able to detect the symbols with the ID number I designated and add them together in my formula.

 

Just in case anyone else ever needs to know how to make Softlist detect and count symbols based on symbol ID here is my formula, and the library listing to show how the symbols must be set.

 

What I learned:

 

*Changes to symbol ID do not always register with Softlist, so this may only work for newer projects (unless you can find a way to make Softlist recognize changes to symbol ID)

 

*Symbols must be set to "Include" in >System Options>Softlist Configuration>Libraries>Symbols

 

*Make sure to set your Material formula to the same ID number you have set for the Symbol(s) you want detected

 

FORMULA

acpld6o.jpg

 

SYSTEM SYMBOL LIBRARY

6XFuX2k.jpg

Attached Thumbnails

  • softlist symbol formula.jpg
  • softlist symbol library.jpg

  • Myron Edwards likes this

#10 Philip Frank

Philip Frank

    Advanced Member

  • Members
  • PipPipPip
  • 418 posts
  • LocationMaine, USA

Posted 29 September 2017 - 04:36 AM

I believe that once you place a symbol in a drawing, it becomes part of the "Drawing Library" not the "System Library". You were making changes to the symbols in the "System Library" when you edited them. I think if you were to reset the "Drawing Library" symbols to the "System" level, it might recognize them in SoftList.


  • Myron Edwards likes this





Also tagged with one or more of these keywords: softlist, symbol, formula, plumbing, material definition

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users